<!DOCTYPE html>
<html class="no-js ">
<head>


<meta charset="utf-8">
<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1"><script type="text/javascript">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</script>
<meta name="description" content="Good Morning America full episode recap, 06/01/2019: 2020 presidential candidates to attend the annual CA Democratic Party convention; 10-year-old girl saves little sister from drowning in pool" />
<meta name="keywords" content="Good Morning America, 06/01/19: Disgruntled Employee Opens Fire at VA Beach Municipal Building: Police, episode recap, episode summary, episode synopsis, 06/01/2019" />
<link rel="alternate" href="android-app://com.disney.datg.videoplatforms.android.abc/abcplayer" />
<link rel="apple-touch-icon" href="//cdn1.edgedatg.com/aws/abc/brand/fall2018/abclogo_57x57.png" />
<link rel="shortcut icon" href="//cdn1.edgedatg.com/aws/abc/brand/fall2018/favicon-abc.ico" />
<meta name="apple-itunes-app" content="app-id=364191819, app-argument=http://abc.go.com/watch-live" />
<meta name="google-play-app" content="app-id=com.disney.datg.videoplatforms.android.abc" />
<meta name="google-site-verification" content="qxz3F4HP0AHtXucYo3rj4unQJ_Uz_-iy_EttfC-zRDU" />
<meta name="msApplication-ID" content="App" />
<meta name="msApplication-PackageFamilyName" content="ABC.ABCPlayer" />
<meta name="msapplication-TileColor" content="#2D2D2D" />
<meta name="msapplication-TileImage" content="//cdn1.edgedatg.com/aws/abc/brand/fall2018/favicon_ie10.png" />
<meta name="msvalidate.01" content="0EABD001D404EA9DDE2025E9E4F14CAF" />
<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=0" />
<meta property="fb:app_id" content="137585909851" />
<meta property="og:app_id" content="137585909851" />
<meta name="og:image" content="https://cdn1.edgedatg.com/aws/v2/abcnews/GoodMorningAmerica/video/9152/088afbc50acaf83ea5cc01baa392fc1e/579x325-Q100_088afbc50acaf83ea5cc01baa392fc1e.jpg" />
<link rel="canonical" href="https://abc.go.com/shows/good-morning-america/episode-guide/2019-06/01-060119-disgruntled-employee-opens-fire-at-va-beach-municipal-building-police" />
<meta name="description" content="Visit The official Good Morning America online at ABC.com. Get exclusive videos, blogs, photos, cast bios, free episodes and more." />
<meta name="twitter:site" content="@{twitter.account}" />
<meta name="twitter:card" content="summary_large_image" />
<meta property="og:description" content="Good Morning America full episode recap: 2020 presidential candidates to attend the annual CA Democratic Party convention; 10-year-old girl saves little sister from drowning in pool" />
<meta name="twitter:image" content="https://cdn1.edgedatg.com/aws/v2/abcnews/GoodMorningAmerica/video/9152/088afbc50acaf83ea5cc01baa392fc1e/579x325-Q100_088afbc50acaf83ea5cc01baa392fc1e.jpg" />
<meta property="og:image" content="https://cdn1.edgedatg.com/aws/v2/abcnews/GoodMorningAmerica/video/9152/088afbc50acaf83ea5cc01baa392fc1e/579x325-Q100_088afbc50acaf83ea5cc01baa392fc1e.jpg" />
<meta property="og:title" content="Good Morning America: 06/01/19: Disgruntled Employee Opens Fire at VA Beach Municipal Building: Police Watch Full Episode | 06/01/2019" />
<meta property="og:url" content="https://abc.go.com/shows/good-morning-america/episode-guide/2019-06/01-060119-disgruntled-employee-opens-fire-at-va-beach-municipal-building-police" />
<meta property="og:site_name" content="ABC" />
<title>Good Morning America: 06/01/19: Disgruntled Employee Opens Fire at VA Beach Municipal Building: Police Watch Full Episode | 06/01/2019</title>
<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=0">
<script type='text/javascript'>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</script>
<script async="async" src="https://www.googletagservices.com/tag/js/gpt.js"></script><script>var googletag=googletag||{};googletag.cmd=googletag.cmd||[];</script><link rel="stylesheet" type="text/css" href="//cdn1.edgedatg.com/aws/site/3.20.4.0/css/production/001/001/abcfonts.css"/>
<link rel="stylesheet" type="text/css" href="//cdn1.edgedatg.com/aws/site/3.20.4.0/css/production/001/001/abc.css"/>
<script type="text/javascript" src="//cdn1.edgedatg.com/aws/site/3.20.4.0/js/production/001/001/modernizr.js"></script>
<script type="text/javascript" src="https://cdn1.edgedatg.com/aws/apps/datg/web-js-telemetry-service/1.0.0.6/production/js/datgts.js"></script>
<script type="text/javascript" src="https://cdn1.edgedatg.com/aws/apps/datg/web-player-unity/1.1.2.23/js/embed.min.js"></script>

<!-- nielsen scripts --> <script type="text/javascript" src="//secure-dcr.imrworldwide.com/novms/js/2/ggcmb510.js"></script><script type="text/javascript">window.addEventListener && window.addEventListener('load', function() {NOLCMB && NOLCMB.getInstance('DCR').ggInitialize({apid: 'P5D99BE17-C04D-4521-9B5D-43B97D3B7A4A', sfcode: 'dcr', apn: 'ABC', nsdkv: '511'});});</script>
<script type="application/ld+json">{"@context":"http://schema.org","@type":"TVEpisode","name":"06/01/19: Disgruntled Employee Opens Fire at VA Beach Municipal Building: Police","@id":"https://abc.go.com/shows/good-morning-america/episode-guide/2019-06/01-060119-disgruntled-employee-opens-fire-at-va-beach-municipal-building-police","episodeNumber":"52","partOfSeason":{"@type":"TVSeason","seasonNumber":"9"},"partOfSeries":{"@type":"TVSeries","name":"Good Morning America","sameAs":""},"potentialAction":[{"@type":"WatchAction","target":{"@type":"EntryPoint","urlTemplate":"https://abc.go.com/shows/good-morning-america/episode-guide/2019-06/01-060119-disgruntled-employee-opens-fire-at-va-beach-municipal-building-police","inLanguage":"en","actionPlatform":["http://schema.org/DesktopWebPlatform","http://schema.org/MobileWebPlatform"]},"expectsAcceptanceOf":[{"@type":"Offer","category":"free","availabilityStarts":"","availabilityEnds":"2019-06-08T00:01:00.000-07:00","eligibleRegion":[{"@type":"Country","name":"US"}]},{"@type":"Offer","category":"externalSubscription","availabilityStarts":"2019-06-01T00:01:00.000-07:00","availabilityEnds":"2019-06-08T00:01:00.000-07:00","eligibleRegion":[{"@type":"Country","name":"US"}]}]}],"releasedEvent":{"@type":"PublicationEvent","startdate":"2019-06-01T07:00:00.000-07:00","location":{"@type":"Country","name":"US"}},"description":"2020 presidential candidates to attend the annual CA Democratic Party convention; 10-year-old girl saves little sister from drowning in pool","url":"https://abc.go.com/shows/good-morning-america/episode-guide/2019-06/01-060119-disgruntled-employee-opens-fire-at-va-beach-municipal-building-police"}</script>
<!-- Access Analytics --> <script src="//cdn.levelaccess.net/accessjs/YW1wMTIxNDA/access.js" type="text/javascript"></script>
<style type="text/css">.m-favoritelistbutton .button i {background-color: rgb(6, 40, 93)}.m-favoritelistbutton .button:hover i {background-color: rgba(6, 40, 93, 0.6)}.m-key-information-box.sticky, .m-key-information-box.legacy {background-color: rgb(17, 91, 184)}.m-key-information-box.non-home, .m-key-information-box.legacy {background-color: rgb(17, 91, 184)}.m-key-information-box .header {background-color: rgb(17, 91, 184)}</style>
<script type="text/javascript">
    !function(t,n){t[n]=t[n]||{nlsQ:function(e,o,c,r,s,i){return s=t.document,r=s.createElement("script"),r.async=1,r.src=("http:"===t.location.protocol?"http:":"https:")+"//cdn-gl.imrworldwide.com/conf/"+e+".js#name="+o+"&ns="+n,i=s.getElementsByTagName("script")[0],i.parentNode.insertBefore(r,i),t[n][o]=t[n][o]||{g:c||{},ggPM:function(e,c,r,s,i){(t[n][o].q=t[n][o].q||[]).push([e,c,r,s,i])}},t[n][o]}}}(window,"NOLBUNDLE");

    var nSdkInstance;

            nSdkInstance = NOLBUNDLE.nlsQ("PBE9B1755-06C4-45F1-8DA8-B1BD010D85F1", "nlsnInstance");
    
    // Content Metadata
    var nielsenMetadata = {
        type: 'static',
        assetid: '1016772',
        section: 'shows',
        segA: '',
        segB: '',
        segC: ''
    };

    nSdkInstance.ggPM("staticstart", nielsenMetadata);
</script>

<script type="text/javascript" src="https://cdn.registerdisney.go.com/v2/outer/DisneyID.js"></script>


</head>
<body  data-l-id="1016772" data-l-name="" data-l-type="" class="butterscotch t-dark butterscotch hide-episode-number hide-season-number inside-show"  data-show-title="Good Morning America">


<!-- crazy egg scripts --> <script type="text/javascript"> setTimeout(function() {var a=document.createElement("script"); var b=document.getElementsByTagName("script")[0]; a.src=document.location.protocol+"//dnn506yrbagrg.cloudfront.net/pages/scripts/0013/8430.js?"+Math.floor(new Date().getTime()/3600000); a.async=true;a.type="text/javascript";b.parentNode.insertBefore(a,b)} , 1); </script><div class="page-wrapper">
    
        
    <div class="header-modules">
        
<header
   data-m-id="52087" data-m-name="main_menu" data-m-type="menu" class="m-menu module flexible-dropdown "
  data-qa="menu.header">
  <div class="m-menu-wrapper">
          <section class="m-mvpdauth">
    <div class="row">            <span class="mvpd-auth-bar-text"></span>
            </div>
</section>        <div class="row m-menu-row">
      <aside class="m-menu-logo-title">
                  <a href="/" tabindex="1" data-qa="menu.logo">
              <picture>
                  <source srcset="https://cdn1.edgedatg.com/aws/assets/cp/web/abc/images/ABC-Default3-2x.png 2x, https://cdn1.edgedatg.com/aws/assets/cp/web/abc/images/ABC-Default3-1x.png 1x" media="(max-width: 320px)"/>
                  <source srcset="https://cdn1.edgedatg.com/aws/assets/cp/web/abc/images/ABC-Default3-2x.png 2x, https://cdn1.edgedatg.com/aws/assets/cp/web/abc/images/ABC-Default3-2x.png 1x" media="(min-width: 321px)"/>

                  <img class="m-menu-logo left" src="https://cdn1.edgedatg.com/aws/assets/cp/web/abc/images/ABC-Default3-1x.png"
                          alt="ABC"/>
              </picture>
          </a>
                <script type="application/ld+json">
                    {
                        "@context": "http://schema.org/",
                        "@type": "abc.com",
                        "url": "http://abc.go.com",
                        "logo": "https://cdn1.edgedatg.com/aws/assets/cp/web/abc/images/ABC-Default3-1x.png"
                    }
                </script>
                                </aside>
      <nav class="m-menu-global-navigation">
                <ul class="m-menu-global-list-navigation inline-list">
                                <li data-t-id="l1" class="primary-item " data-qa="menu.item-l1" >
                    <div class="m-menu-global-section">
                      <a class="light white m-menu-item m-menu--link"
                         href="/shows"
                         target="_self" tabindex="2" data-is-modal-trigger="0"
                                               >
                        shows                                              </a>
                    </div>
                  </li>
                                        <li data-t-id="l2" class="primary-item " data-qa="menu.item-l2" >
                    <div class="m-menu-global-section">
                      <a class="light white m-menu-item m-menu-live-link"
                         href="/watch-live"
                         target="_self" tabindex="3" data-is-modal-trigger="0"
                                               >
                        live                                              </a>
                    </div>
                  </li>
                                        <li data-t-id="l3" class="primary-item " data-qa="menu.item-l3" >
                    <div class="m-menu-global-section">
                      <a class="light white m-menu-item m-menu--link"
                         href="/schedule"
                         target="_self" tabindex="4" data-is-modal-trigger="0"
                                               >
                        schedule                                              </a>
                    </div>
                  </li>
                                        <li data-t-id="l5" class="primary-item " data-qa="menu.item-l5" >
                    <div class="m-menu-global-section">
                      <a class="light white m-menu-item m-menu-account-link"
                         href="#"
                         target="_self" tabindex="5" data-is-modal-trigger="1"
                         
data-t-m-click="{&quot;click&quot;:{&quot;element_type&quot;:&quot;menu item&quot;,&quot;title&quot;:&quot;account&quot;,&quot;uri&quot;:&quot;https:\/\/api.presentation.abc.go.com\/api\/ws\/presentation\/v2\/module\/52087.json?brand=001&amp;device=001&amp;authlevel=0&amp;show=SH5587637&quot;,&quot;content_id&quot;:&quot;52087&quot;,&quot;item_position&quot;:4}}"
                      >
                        account                                              </a>
                    </div>
                  </li>
                                           <li class="primary-item-more"
            data-t-id="l4"            data-qa="menu.item-more">
              <div class="m-menu-global-section">
                <a class="light white m-menu-global-link" href="#" tabindex="6">
                  More
                </a>
              </div>
            </li><!--
          --><!--
          -->      </ul>
      </nav>
              <div class="m-menu-global-navigation-search-icon">
            <a
                class="m-menu-search-link"
                href="#"
                data-qa="menu.search-icon"
                tabindex="16"
                
data-t-m-click="{&quot;click&quot;:{&quot;element_type&quot;:&quot;link&quot;,&quot;title&quot;:&quot;Search&quot;}}"
                data-t-id="l0"            >
                <span class="abc-icon-magnify-glass icon"></span> <span class="search-cta">Search</span>
            </a>

            
<div class="m-menu-search-block">
    <span class="abc-icon-magnify-glass icon search-field-icon"></span>
    <input class="search-field" type="text" placeholder="search for a show" />
    <a
        href="#"
        class="search-field-close abc-icon-close icon"
        
data-t-m-click="{&quot;click&quot;:{&quot;element_type&quot;:&quot;link&quot;,&quot;title&quot;:&quot;Close&quot;},&quot;page_name&quot;:&quot;abc:search&quot;}"
        data-t-id="l0"    ></a>
</div>
        </div>
          </div>
  </div>
        <div class="m-menu-drop-nav m-menu-show-drop-nav show-for-large-up">
    <div class="row">
        <div class="columns navigation-group">
            <header class="m-menu-drop-nav-header show-for-large-up">
                <span class="navigation-group-link text4 grey navtitle">Shows</span>
                <hr/>
            </header>
            <ul class="show-list-navigation navigation-group no-list-style">
                <li class="expandable-list"><!--
                 --><a class="hide-for-large-up extra-light dark-text expanded-list-title"
                       href="#">Shows <!--
                    --><span class="abc-icon-arrow-down icon expand-arrow"></span><!--
                --></a>
                    <ul class="m-menu-link-list collapsed-list">
                                                <li class="m-menu-link-list-item" data-t-id="">
                            <a tabindex="17" class="button navigation-group-link subtitle m-menu-shows-all-link lowercase" href="/shows">view all shows</a>
                        </li>
                    </ul>
                </li>
            </ul>
        </div>
    </div>
</div>
    <div class="m-menu-drop-nav m-menu-global-drop-nav">
    <div class="row">
        <div class="columns navigation-group">
            <header class="m-menu-drop-nav-header">
                <span
                    class="navigation-group-link text4 grey navtitle">abc.com</span>
                <hr/>
            </header>
            <ul class="show-list-navigation navigation-group m-menu-link-list">
                
                        <li class="m-menu-link-list-item" data-t-id="l16">
                            <span class="navigation-group-link text-header-nav extra-light"><a
                                    href="https://www.goodmorningamerica.com/"
                                    target="_self"
                                    class="faded-grey" tabindex="7">good morning america</a></span>
                        </li>

                    
                        <li class="m-menu-link-list-item" data-t-id="l17">
                            <span class="navigation-group-link text-header-nav extra-light"><a
                                    href="http://oscar.go.com"
                                    target="_self"
                                    class="faded-grey" tabindex="8">oscar.com</a></span>
                        </li>

                    
                        <li class="m-menu-link-list-item" data-t-id="l18">
                            <span class="navigation-group-link text-header-nav extra-light"><a
                                    href="/my-profile"
                                    target="_self"
                                    class="faded-grey" tabindex="9">continue watching</a></span>
                        </li>

                    
                        <li class="m-menu-link-list-item" data-t-id="l19">
                            <span class="navigation-group-link text-header-nav extra-light"><a
                                    href="/apps"
                                    target="_self"
                                    class="faded-grey" tabindex="10">apps</a></span>
                        </li>

                    
                        <li class="m-menu-link-list-item" data-t-id="l20">
                            <span class="navigation-group-link text-header-nav extra-light"><a
                                    href="/music-lounge"
                                    target="_self"
                                    class="faded-grey" tabindex="11">music</a></span>
                        </li>

                    
                        <li class="m-menu-link-list-item" data-t-id="l21">
                            <span class="navigation-group-link text-header-nav extra-light"><a
                                    href="http://abcnews.go.com"
                                    target="_self"
                                    class="faded-grey" tabindex="12">ABC News</a></span>
                        </li>

                    
                        <li class="m-menu-link-list-item" data-t-id="l22">
                            <span class="navigation-group-link text-header-nav extra-light"><a
                                    href="http://freeform.go.com"
                                    target="_self"
                                    class="faded-grey" tabindex="13">freeform</a></span>
                        </li>

                    
                        <li class="m-menu-link-list-item" data-t-id="l23">
                            <span class="navigation-group-link text-header-nav extra-light"><a
                                    href="https://support.abc.com"
                                    target="_self"
                                    class="faded-grey" tabindex="14">FAQ</a></span>
                        </li>

                    
                        <li class="m-menu-link-list-item" data-t-id="l24">
                            <span class="navigation-group-link text-header-nav extra-light"><a
                                    href="http://www.abcbeinspired.com/"
                                    target="_self"
                                    class="faded-grey" tabindex="15">corporate social responsibility</a></span>
                        </li>

                                                </ul>
        </div>
    </div>
</div>
</header>
                <section id="m-key-information-box-shadow" class="legacy"></section>
<section  data-m-id="2227653" data-m-name="key_information_box" data-m-type="freetext"     class="module m-freetext m-key-information-box legacy "
    data-is-legacy="1">
    <div class="header module-row">
        <div class="show-logo-image">
            <a href="/shows/good-morning-america" class="back-arrow">
                <i class="icon abc-icon-backarrow-heavy"></i>
            </a>
                            <a href="/shows/good-morning-america">
                    <img class="lazyload" data-src="https://cdn1.edgedatg.com/aws/v2/abc/GoodMorningAmerica/showimages/ab721fb44c0108175dafe4d2034f952c/350x117-Q80_ab721fb44c0108175dafe4d2034f952c.png" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" data-fallback-text alt="Good Morning America" />
                </a>
                    </div>
        <div class="buttons m-favoritelistbutton" data-show-id="SH5587637">
            <button class="button list-action remove-from-my-list">
                <i class="icon abc-icon-check"></i>
                <span>My List</span>
            </button>
                                        <button class="button list-action add-to-list">
                                <i class="icon abc-icon-abc-web-mylist-add"></i>
                                <span>MY LIST</span>
                            </Button>
                                                </div>
    </div>
</section>
    </div>

    
<section
     data-m-id="2148899" data-m-name="searchlist_2148899" data-m-type="searchlist"     class="module m-searchlist"
            data-api-url="https://api.pluto.watchabc.go.com/api/ws/pluto/v1/module/searchlist/2148899?brand=001&device=001&authlevel=0&layout=1016772&start={start}&size={size}&q={query}"
                data-img-config="{&quot;web&quot;:{&quot;width&quot;:&quot;244&quot;},&quot;web-retina&quot;:{&quot;width&quot;:&quot;280&quot;},&quot;tablet&quot;:{&quot;width&quot;:&quot;317&quot;},&quot;tablet-retina&quot;:{&quot;width&quot;:&quot;634&quot;},&quot;mobile&quot;:{&quot;width&quot;:&quot;244&quot;},&quot;mobile-retina&quot;:{&quot;width&quot;:&quot;280&quot;},&quot;default&quot;:{&quot;width&quot;:&quot;1&quot;}}"
        data-module-id="2148899"
>
    <div class="m-modal modal-overlay">
        <div class="modal">
            <div class="search-results">
                <ul class="tiles small-block-grid-2 medium-block-grid-2 large-block-grid-4 xlarge-block-grid-5 slider-strip row nogutter"></ul>

                <p class="no-results">Sorry, there are no matching results.</p>
            </div>
        </div>
    </div>
</section>

    <main class="content region " data-qa="background.container">
                <div class="modules">
                        <section
     data-m-id="801981" data-m-name="messages" data-m-type="messages"     class="module m-message module-static row ">
    <div class="columns large-3 m-message-alert-icon">
        <span class="icon abc-icon-alert"></span>
    </div>
    <div class="columns large-8 messages-wrapper"></div>
    <div class="close columns large-1">
        <div class="abc-icon-close iconfont"></div>
    </div>
</section>            <section
     data-m-id="80068" data-m-name="videoplayer_80068" data-m-type="videoplayer"     class="module m-videoplayer m-videoplayer-lf"
    data-has-affiliate-logo="1"
    data-module-type="videoplayer"
    data-embed-mvpd-picker="1"
    data-embed-roadblock="1"
    >
        
    <div class="m-videoplayer-wrapper">
        <div class="row m-videoplayer-videoplayer">
            <div class="aspectBuffer"></div>
            <div class="videoContainer m-videoplayer-embed m-videoplayer-embed-lf"

            data-video-id="VDKA10071622" data-video-tags="Good Morning America, 06/01/19: Disgruntled Employee Opens Fire at VA Beach Municipal Building: Police, episode recap, episode summary, episode synopsis, 06/01/2019" data-is-digital-only="false" data-accesslevel="1"width="100%" height="100%" data-autoplay="true" data-language="en"            data-image-web="https://cdn1.edgedatg.com/aws/abc/Shows/episode-abc_logo_default_gray_16-9-1000x563-Q90_1409810018758.jpg" >
                <div id="playerContainer" class="datgPlayer m-videoplayer-container">
    <div class="datgUi loading"></div>
</div>    <picture class="background fluid-img lazyload not-visible">
                <source class="mobile-source"
                data-srcset="https://cdn1.edgedatg.com/aws/abc/Shows/episode-abc_logo_default_gray_16-9-512x288-Q90_1409810018758.jpg 2x, https://cdn1.edgedatg.com/aws/abc/Shows/episode-abc_logo_default_gray_16-9-320x180-Q90_1409810018758.jpg 1x"
                media="(max-width: 671px)"/>
                        <source class="tablet-source"
                data-srcset="https://cdn1.edgedatg.com/aws/abc/Shows/episode-abc_logo_default_gray_16-9-1228x691-Q90_1409810018758.jpg 2x, https://cdn1.edgedatg.com/aws/abc/Shows/episode-abc_logo_default_gray_16-9-768x432-Q90_1409810018758.jpg 1x"
                media="(max-width: 999px)"/>
                        <source class="web-source"
                data-srcset="https://cdn1.edgedatg.com/aws/abc/Shows/episode-abc_logo_default_gray_16-9-1600x900-Q90_1409810018758.jpg 2x, https://cdn1.edgedatg.com/aws/abc/Shows/episode-abc_logo_default_gray_16-9-1000x563-Q90_1409810018758.jpg 1x"
                media="(min-width: 1000px)"/>
                        <img
            data-src="https://cdn1.edgedatg.com/aws/abc/Shows/episode-abc_logo_default_gray_16-9-320x180-Q90_1409810018758.jpg"
            src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw=="            class="lazyload fluid-img"
            alt="" />
            </picture>
            </div>
        </div>
    </div>

    <div class="row m-videoplayer-content-row">
        <div id="recap" class="m-videoplayer-content m-videoplayer-content-lf">
    <header class="m-videoplayer-header">
                    <div class="affilate-logo"></div>
                <h1 class="text2 extra-light m-videoplayer-title light has-affilate">
            <span class="season-number">S9 </span>
            <span class="episode-number">E52 </span>
            <span class="m-videoplayer-episode-title">06/01/19: Disgruntled Employee Opens Fire at VA Beach Municipal Building: Police</span>
        </h1>
    </header>
    <hr class="m-videoplayer-hr"/>
    <div class="m-videoplayer-episodemeta text5 grey">32:32 | 06/01/19 | NR | CC</div>

    <section class="m-expandable-text">
        <div class="m-videoplayer-summary expandable-section">
            2020 presidential candidates to attend the annual CA Democratic Party convention; 10-year-old girl saves little sister from drowning in pool        </div>
        <a href="#" class="continue-reading">Continue Reading
            <span class="abc-icon-arrow-down icon"></span>
        </a>
    </section>
</div>    </div>
</section>
        </div>
    </main>

    <div class="footer-modules">
        <section  data-m-id="480446" data-m-name="breadcrumbs" data-m-type="breadcrumbs"     class="module module-row row ">
    <div id="breadcrumb-data">
        <nav class="breadcrumbs">
            <ul class="inline-list">
                                        <li class="breadcrumb" itemscope itemtype="http://data-vocabulary.org/Breadcrumb">
                            <span class="abc-icon-arrow-right breadcrumb-icon"></span>
                            <a href="/shows/good-morning-america"  class="breadcrumb-link" itemprop="url"
                               title="what's on tonight Good Morning America">
                                <span class="extra-light text7" itemprop="title">Good Morning America</span>
                            </a>
                        </li>
                                            <li class="breadcrumb" itemscope itemtype="http://data-vocabulary.org/Breadcrumb">
                            <span class="abc-icon-arrow-right breadcrumb-icon"></span>
                            <a href="/shows/good-morning-america/episode-guide/2019-06/01-060119-disgruntled-employee-opens-fire-at-va-beach-municipal-building-police"  class="breadcrumb-link" itemprop="url"
                               title="what's on tonight 06/01/19: Disgruntled Employee Opens Fire at VA Beach Municipal Building: Police">
                                <span class="extra-light text7" itemprop="title">06/01/19: Disgruntled Employee Opens Fire at VA Beach Municipal Building: Police</span>
                            </a>
                        </li>
                                </ul>
        </nav>
    </div>
</section>                <footer  data-m-id="589244" data-m-name="footer_menu" data-m-type="menu" class="module m-footer "
>
    <div class="row">
        <section class="columns">
                            <ul class="m-footer-links no-list-style">
                                                <li class="m-footer-link"><a class="extra-light grey lowercase"
                                 href="/info"
                                 title="company info"
                                 target="_self">company info</a>
    </li>
                                                <li class="m-footer-link"><a class="extra-light grey lowercase"
                                 href="/feedback"
                                 title="contact"
                                 target="_self">contact</a>
    </li>
                                                <li class="m-footer-link"><a class="extra-light grey lowercase"
                                 href="http://preferences-mgr.truste.com/?type=abc&affiliateId=115"
                                 title="interest-based ads"
                                 target="_blank">interest-based ads</a>
    </li>
                                                <li class="m-footer-link"><a class="extra-light grey lowercase"
                                 href="http://disneytermsofuse.com/"
                                 title="terms of use"
                                 target="_blank">terms of use</a>
    </li>
                                                <li class="m-footer-link"><a class="extra-light grey lowercase"
                                 href="http://disneyprivacycenter.com/"
                                 title="privacy policy"
                                 target="_blank">privacy policy</a>
    </li>
                                                <li class="m-footer-link"><a class="extra-light grey lowercase"
                                 href="https://privacy.thewaltdisneycompany.com/en/current-privacy-policy/your-california-privacy-rights/"
                                 title="your california privacy rights"
                                 target="_blank">your california privacy rights</a>
    </li>
                                                <li class="m-footer-link"><a class="extra-light grey lowercase"
                                 href="https://disneyprivacycenter.com/kids-privacy-policy/english/"
                                 title="children's online privacy policy"
                                 target="_blank">children's online privacy policy</a>
    </li>
                                                <li class="m-footer-link"><a class="extra-light grey lowercase"
                                 href="/closed-captioning"
                                 title="closed captioning"
                                 target="_self">closed captioning</a>
    </li>
                                                <li class="m-footer-link"><a class="extra-light grey lowercase"
                                 href="http://www.nielsen.com/digitalprivacy"
                                 title="about Nielsen measurement"
                                 target="_blank">about Nielsen measurement</a>
    </li>
                                                        </ul>
                        <div class="m-footer-social-links">
                                    <a class="icon light-grey abc-icon-twitter" href="http://twitter.com/ABCNetwork"
                       target="_blank"
                       title="Twitter"></a>
                                                    <a class="icon light-grey abc-icon-facebook" href="http://www.facebook.com/ABCNetwork?ref=ts"
                       target="_blank" title="Facebook"></a>
                                                    <a class="icon light-grey abc-icon-googleplus" href="https://plus.google.com/+ABCNetwork"
                       target="_blank" title="Google+"></a>
                            </div>
        </section>
    </div>
</footer>    </div>

</div>

<section  data-m-id="virtual" data-m-name="favoritelistactioncta" data-m-type="favoritelistactioncta"  class="module m-favoritelistactioncta">
    <div class="m-modal modal-overlay">
        <div class="modal">
            <a href="#" class="modal-close close">
                <span 
data-t-m-click="{&quot;click&quot;:{&quot;element_type&quot;:&quot;modal&quot;,&quot;title&quot;:&quot;close&quot;},&quot;page_name_section&quot;:&quot;mylistcta&quot;}"
 class="icon abc-icon-close"></span>
            </a>
            <div class="logo"></div>
            <p class="action-notification">Good Morning America has been added to My List.</p>
            <div class="show-image ">
                    <picture class="background fluid-img lazyload">
                <source class="mobile-source"
                srcset="https://cdn1.edgedatg.com/aws/v2/abcnews/GoodMorningAmerica/showimages/603c73b29bef18b63d048dc32dccbc32/196x261-Q80_603c73b29bef18b63d048dc32dccbc32.jpg 2x, https://cdn1.edgedatg.com/aws/v2/abcnews/GoodMorningAmerica/showimages/603c73b29bef18b63d048dc32dccbc32/196x261-Q80_603c73b29bef18b63d048dc32dccbc32.jpg 1x"
                media="(max-width: 671px)"/>
                        <source class="tablet-source"
                srcset="https://cdn1.edgedatg.com/aws/v2/abcnews/GoodMorningAmerica/showimages/603c73b29bef18b63d048dc32dccbc32/196x261-Q80_603c73b29bef18b63d048dc32dccbc32.jpg 2x, https://cdn1.edgedatg.com/aws/v2/abcnews/GoodMorningAmerica/showimages/603c73b29bef18b63d048dc32dccbc32/196x261-Q80_603c73b29bef18b63d048dc32dccbc32.jpg 1x"
                media="(max-width: 999px)"/>
                        <source class="web-source"
                srcset="https://cdn1.edgedatg.com/aws/v2/abcnews/GoodMorningAmerica/showimages/603c73b29bef18b63d048dc32dccbc32/196x261-Q80_603c73b29bef18b63d048dc32dccbc32.jpg 2x, https://cdn1.edgedatg.com/aws/v2/abcnews/GoodMorningAmerica/showimages/603c73b29bef18b63d048dc32dccbc32/196x261-Q80_603c73b29bef18b63d048dc32dccbc32.jpg 1x"
                media="(min-width: 1000px)"/>
                        <img
            src="https://cdn1.edgedatg.com/aws/v2/abcnews/GoodMorningAmerica/showimages/603c73b29bef18b63d048dc32dccbc32/140x187-Q90_603c73b29bef18b63d048dc32dccbc32.jpg"
                        class="fluid-img"
            alt="" />
            </picture>
            </div>
            <p class="promo-text">Create an ABC Account to save your favorite shows and continue watching where your left off.</p>
            <div class="buttons-group">
                <button class="oneid-action sign-up" 
data-t-m-click="{&quot;click&quot;:{&quot;element_type&quot;:&quot;modal&quot;,&quot;title&quot;:&quot;create an account&quot;},&quot;page_name_section&quot;:&quot;mylistcta&quot;}"
>create an account</button>
                <div class="clearfix"></div>
            </div>
            <div class="sign-up-text">
                Already have an account? <a 
data-t-m-click="{&quot;click&quot;:{&quot;element_type&quot;:&quot;modal&quot;,&quot;title&quot;:&quot;sign in&quot;},&quot;page_name_section&quot;:&quot;mylistcta&quot;}"
 href="#" class="oneid-action sign-in link">sign in</a>
            </div>
            <div class="skip-text">
                <a 
data-t-m-click="{&quot;click&quot;:{&quot;element_type&quot;:&quot;modal&quot;,&quot;title&quot;:&quot;skip&quot;},&quot;page_name_section&quot;:&quot;mylistcta&quot;}"
 href="#" class="modal-close link" data-t-id="l27">skip</a>
            </div>
        </div>
    </div>
</section>
<section  data-m-id="virtualAccountModule" data-m-name="" data-m-type="account"  class="module m-account account">
    <div class="m-modal modal-overlay">
        <div class="modal">
            <a href="#" class="modal-close close">
                <span 
data-t-m-click="{&quot;click&quot;:{&quot;element_type&quot;:&quot;modal&quot;,&quot;title&quot;:&quot;close&quot;}}"
 class="icon abc-icon-close"></span>
            </a>
            <div class="oneid-unauthenticated">
                <div class="logo"></div>
                <p class="heading">Create an ABC Account to get the most of your ABC experience</p>
                <ul class="bullet-list">
                    <li><i class='abc-icon-triangle-bullet'></i> Save your favorite shows to My List</li><li><i class='abc-icon-triangle-bullet'></i> Continue watching where you left off</li><li><i class='abc-icon-triangle-bullet'></i> Watch hundreds of hours of free episodes</li><li><i class='abc-icon-triangle-bullet'></i> One account that works across the Walt Disney Family of Companies</li>                </ul>
                <div class="buttons-group">
                    <button
                        class="oneid-action sign-up button"
                        
data-t-m-click="{&quot;click&quot;:{&quot;element_type&quot;:&quot;modal&quot;,&quot;title&quot;:&quot;create an account&quot;},&quot;page_name_section&quot;:&quot;unauthenticated&quot;}"
                        data-t-id="l28"
                    >create an account</button>
                </div>
                <div class="sign-up-text">
                    Already have an account? <a href="#" 
data-t-m-click="{&quot;click&quot;:{&quot;element_type&quot;:&quot;modal&quot;,&quot;title&quot;:&quot;sign in&quot;},&quot;page_name_section&quot;:&quot;unauthenticated&quot;}"
 class="oneid-action sign-in link" data-t-id="l29">sign in</a>
                </div>
            </div>
            <div class="oneid-authenticated">
                <div class="logo"></div>
                <p class="heading">ABC Profile</p>
                <p class="oneid-name"></p>
                <p class="oneid-email"></p>
                <button 
data-t-m-click="{&quot;click&quot;:{&quot;element_type&quot;:&quot;modal&quot;,&quot;title&quot;:&quot;Account Information&quot;},&quot;page_name_section&quot;:&quot;authenticated&quot;}"
 class="oneid-action view-account button" data-t-id="l30">Account Information</button>
                <a 
data-t-m-click="{&quot;click&quot;:{&quot;element_type&quot;:&quot;modal&quot;,&quot;title&quot;:&quot;sign out&quot;},&quot;page_name_section&quot;:&quot;authenticated&quot;}"
 class="oneid-action sign-out" href="#" data-t-id="l31">sign out</a>
            </div>
            <div class="sign-out-confirmation">
                <div class="logo"></div>
                <p class="heading">Sign Out</p>
                <p class="subheading">Are you sure you want to sign out?</p>
                <p class="info">By signing out, you will not be able to resume watching content where you left off, enjoy cross-device viewing experience, or save your favorites to your My List.</p>
                <button 
data-t-m-click="{&quot;click&quot;:{&quot;element_type&quot;:&quot;modal&quot;,&quot;title&quot;:&quot;sign out&quot;},&quot;page_name_section&quot;:&quot;signoutconfirmation&quot;}"
 class="oneid-action sign-out-confirmed button" data-t-id="l32">sign out</button>
                <a 
data-t-m-click="{&quot;click&quot;:{&quot;element_type&quot;:&quot;modal&quot;,&quot;title&quot;:&quot;cancel&quot;},&quot;page_name_section&quot;:&quot;signoutconfirmation&quot;}"
 class="oneid-action cancel" href="#" data-t-id="l33">cancel</a>
            </div>
            <div class="mvpd-sign-out-confirmation">
                <div class="logo"></div>
                <p class="heading">Sign Out</p>
                <p class="subheading">Are you sure?</p>
                <p class="info">By signing out, some episodes will become unavailable to watch until you sign back in.</p>
                <button 
data-t-m-click="{&quot;click&quot;:{&quot;element_type&quot;:&quot;modal&quot;,&quot;title&quot;:&quot;sign out&quot;},&quot;page_name_section&quot;:&quot;mvpdsignoutconfirmation&quot;}"
 class="mvpd-action sign-out-confirmed button" data-t-id="l34">sign out</button>
                <a 
data-t-m-click="{&quot;click&quot;:{&quot;element_type&quot;:&quot;modal&quot;,&quot;title&quot;:&quot;stay signed in&quot;},&quot;page_name_section&quot;:&quot;mvpdsignoutconfirmation&quot;}"
 class="mvpd-action cancel" href="#" data-t-id="l35">stay signed in</a>
            </div>
                            <div class="mvpd-sign-out" style="display: none" data-t-id="l26"
                     data-tabindex-mvpd="18"
                     data-tabindex-sign-out="19">
                </div>
                    </div>
    </div>
</section>

<script type="text/javascript">
    (function () {
                var fwmrmRandomNumber = Math.floor(Math.random() * 100000) + 10000;
        window._fw_linktag_params = {
            scan_delay: 0,
            allow_rescan_after: 15000,
                        server: "2912a.v.fwmrm.net",
            network_id: "168234",
            profile: "abc_bc_linktag2_live",
            other_global_params: "csid=abc_fep_fepplayer&caid=2019-06;target=01-060119-disgruntled-employee-opens-fire-at-va-beach-municipal-building-police&sfid=109036&pvrn=" + fwmrmRandomNumber,
            key_values: ""
        };

                var r = function (){
            var e = function () {
                if (document.addEventListener) document.removeEventListener('DOMContentLoaded', e, false);
                else window.detachEvent('onload', e);
                window._fw_page_ready = true;
            };
            if (document.addEventListener) document.addEventListener('DOMContentLoaded', e, false);
            else if (window.attachEvent) window.attachEvent('onload', e);
                        var lt = document.createElement('script');
            lt.type = 'text/javascript';
            lt.async = true;

                        lt.src = "https://mssl.fwmrm.net/p/abc_live/LinkTag2.js";
            
                        var s = document.getElementsByTagName('script')[0];
            s.parentNode.insertBefore(lt, s);
                    };
                window._fw_embed = r;
            })();
</script><script type="text/javascript">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</script>



<script type="text/javascript" src="https://cdn.unid.go.com/js/unid.min.js" data-client="DATG-ABCDOTCOM.WEB"></script>
<script type="text/javascript" src="//cdn1.edgedatg.com/aws/site/3.20.4.0/js/production/001/001/datg.js"></script>
    <!-- SITE BUILD NUMBER: 3.20.4.0 -->
<!-- CORE BUILD NUMBER: 2.22.2.8 -->

<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","licenseKey":"8d01ff17d1","applicationID":"7645344","transactionName":"NVNRYRdWV0tQWxcIXQwZcEAWQ1ZVHl0TCEENUlYYHFJYShxVDA9GCg==","queueTime":0,"applicationTime":171,"atts":"GRRGF19MRBQTWUFbSR9L","errorBeacon":"bam.nr-data.net","agent":""}</script></body>
</html>